{"action":"Upgrade xrdp to 0.9.21.1-1+deb12u3 or later.","affected":[{"fixed":"0.9.21.1-1+deb12u3","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.9.21.1-1+deb12u3"],"id":"tcs_01M5NRYZD96GH576AQTQ5AWNE6","modified_at":"2026-10-25T09:47:31.690788974Z","published_at":"2026-07-20T17:17:08.460Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-41521","https://security-tracker.debian.org/tracker/CVE-2026-41521"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-41521","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-41521"}],"summary":"xrdp is an open source RDP server. Versions 0.10.6 and prior contain an integer overflow vulnerability when processing screen update messages within the vnc-any connection mode. A malicious remote VNC"}