{"action":"Upgrade libyaml-syck-perl to 1.36-2 or later.","affected":[{"fixed":"1.36-2","introduced":"0"}],"component":"libyaml-syck-perl","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.36-2"],"id":"tcs_01M5NRZCNCZMHSTKQVER21MC3A","modified_at":"2026-10-01T03:03:04.719095434Z","published_at":"2026-03-16T23:16:21.543Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-4177","https://security-tracker.debian.org/tracker/CVE-2026-4177"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-4177#Debian:14/libyaml-syck-perl","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-4177"}],"summary":"YAML::Syck versions through 1.36 for Perl has several potential security vulnerabilities including a high-severity heap buffer overflow in the YAML emitter. The heap overflow occurs when class names e"}