{"action":"Upgrade node-axios to 1.15.2-1 or later.","affected":[{"fixed":"1.15.2-1","introduced":"0"}],"component":"node-axios","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.15.2-1"],"id":"tcs_01M5NRZWEXFD4S7RCDVAZCAHB9","modified_at":"2026-10-01T03:03:11.717215656Z","published_at":"2026-04-24T18:16:30.273Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-42035","https://security-tracker.debian.org/tracker/CVE-2026-42035"],"severity":{"label":"high","score":7.4},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-42035#Debian:14/node-axios","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-42035"}],"summary":"Axios is a promise based HTTP client for the browser and Node.js. Prior to 1.15.1 and 0.31.1, a prototype pollution gadget exists in the Axios HTTP adapter (lib/adapters/http.js) that allows an attack"}