{"action":"Upgrade rust-russh to 0.64.1-1 or later.","affected":[{"fixed":"0.64.1-1","introduced":"0"}],"component":"rust-russh","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.64.1-1"],"id":"tcs_01M5NS045Y2AQ2Q9A8CTN98QAG","modified_at":"2026-10-27T09:47:37.534606228Z","published_at":"2026-05-08T20:16:31.443Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-42189","https://security-tracker.debian.org/tracker/CVE-2026-42189"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-42189","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-42189"}],"summary":"Russh is a Rust SSH client & server library. Prior to version 0.60.1, a pre-authentication denial-of-service vulnerability exists in the server's keyboard-interactive authentication handler. A malicio"}