{"action":"Upgrade unbound to 1.25.1-1 or later.","affected":[{"fixed":"1.25.1-1","introduced":"0"}],"component":"unbound","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.25.1-1"],"id":"tcs_01M5NS1AHFM157SPP4TJTR8R4T","modified_at":"2026-10-01T03:03:12.151675439Z","published_at":"2026-05-20T10:16:27.760Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-42944","https://security-tracker.debian.org/tracker/CVE-2026-42944"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-42944#Debian:14/unbound","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-42944"}],"summary":"NLnet Labs Unbound 1.14.0 up to and including version 1.25.0 has a vulnerability that results in heap overflow when encoding multiple NSID and/or DNS Cookie EDNS and/or EDNS Padding options in the rep"}