{"action":"Upgrade xrdp to 0.9.21.1-1+deb12u3 or later.","affected":[{"fixed":"0.9.21.1-1+deb12u3","introduced":"0"}],"component":"xrdp","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["0.9.21.1-1+deb12u3"],"id":"tcs_01M5NS7EF52Z8F3S0FJRSW646B","modified_at":"2026-10-25T09:47:32.128857678Z","published_at":"2026-07-20T17:17:09.060Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-44178","https://security-tracker.debian.org/tracker/CVE-2026-44178"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-44178","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-44178"}],"summary":"xrdp is an open source RDP server. Versions 0.10.6 and prior contain a heap-based buffer overflow vulnerability within the virtual channel forwarding mechanism. When forwarding data from a remote clie"}