{"action":"Upgrade ruby-css-parser to 2.1.0-1 or later.","affected":[{"fixed":"2.1.0-1","introduced":"0"}],"component":"ruby-css-parser","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.1.0-1"],"id":"tcs_01M5NS7P155VM6QDFVHCTKQXWT","modified_at":"2026-10-27T09:47:39.891559450Z","published_at":"2026-05-14T17:16:22.393Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-44312","https://security-tracker.debian.org/tracker/CVE-2026-44312"],"severity":{"label":"medium","score":5.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-44312#Debian:14/ruby-css-parser","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-44312"}],"summary":"css_parser is a Ruby CSS parser. Prior to 2.1.0 and 1.22.0, the CSS Parser gem does not validate HTTPS connections, allowing a Man-in-the-Middle (MITM) attacker to inject or modify CSS content when st"}