{"action":"Upgrade node-ws to 8.20.1+~cs14.19.1-1 or later.","affected":[{"fixed":"8.20.1+~cs14.19.1-1","introduced":"0"}],"component":"node-ws","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["8.20.1+~cs14.19.1-1"],"id":"tcs_01M5NS9PX34KBJ0RM2FE1T8CBV","modified_at":"2026-10-01T03:03:14.827326008Z","published_at":"2026-05-15T15:16:54.103Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-45736","https://security-tracker.debian.org/tracker/CVE-2026-45736"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-45736#Debian:14/node-ws","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-45736"}],"summary":"ws is an open source WebSocket client and server for Node.js. Prior to 8.20.1, the websocket.close() implementation is vulnerable to uninitialized memory disclosure when a TypedArray is passed as the"}