{"action":"Upgrade thrift to 0.24.0-2 or later.","affected":[{"fixed":"0.24.0-2","introduced":"0"}],"component":"thrift","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.24.0-2"],"id":"tcs_01M5NSKMA69KNKCZ5GQKFERJGQ","modified_at":"2026-10-27T23:00:27.725250582Z","published_at":"2026-07-27T12:16:44.700Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-48144","https://security-tracker.debian.org/tracker/CVE-2026-48144"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-48144#Debian:14/thrift","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-48144"}],"summary":"Improper Validation of Certificate with Host Mismatch vulnerability in Apache Thrift c_glib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24."}