{"action":"Upgrade thrift to 0.24.0-2 or later.","affected":[{"fixed":"0.24.0-2","introduced":"0"}],"component":"thrift","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.24.0-2"],"id":"tcs_01M5NSND9KFQBBM16GP2C5DKSZ","modified_at":"2026-10-27T23:00:30.561523747Z","published_at":"2026-07-27T12:16:45.113Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-49158","https://security-tracker.debian.org/tracker/CVE-2026-49158"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-49158#Debian:14/thrift","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-49158"}],"summary":"Improper Handling of Highly Compressed Data (Data Amplification) vulnerability in Apache Thrift Ruby bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to vers"}