{"action":"Upgrade node-systeminformation to 5.31.7-1 or later.","affected":[{"fixed":"5.31.7-1","introduced":"0"}],"component":"node-systeminformation","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["5.31.7-1"],"id":"tcs_01M5NSPTMJ16VS09X8GXYHPFXX","modified_at":"2026-10-25T09:47:30.621471645Z","published_at":"2026-07-17T20:17:24.857Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-50289","https://security-tracker.debian.org/tracker/CVE-2026-50289"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-50289","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-50289"}],"summary":"systeminformation is a System and OS information library for node.js. Prior to 5.31.7, networkInterfaces() on Linux is vulnerable to OS command injection through the Debian/Ubuntu interfaces(5) source"}