{"action":"Upgrade ruby-excon to 1.5.0-1 or later.","affected":[{"fixed":"1.5.0-1","introduced":"0"}],"component":"ruby-excon","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.5.0-1"],"id":"tcs_01M5NSYCT2WJE90YNB2GZBC0TX","modified_at":"2026-10-01T03:03:26.709543487Z","published_at":"2026-07-17T20:17:26.500Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-54171","https://security-tracker.debian.org/tracker/CVE-2026-54171"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-54171#Debian:14/ruby-excon","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-54171"}],"summary":"Excon is usable, fast, simple HTTP 1.1 for Ruby. Prior to 1.5.0, Excon's RedirectFollower middleware failed to strip additional sensitive headers when following redirects and did not provide a custom"}