{"action":"Upgrade glibc to 2.43-3 or later.","affected":[{"fixed":"2.43-3","introduced":"0"}],"component":"glibc","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.43-3"],"id":"tcs_01M5NSYPPR66KDQJBQD3XKETVN","modified_at":"2026-10-01T03:03:26.331995035Z","published_at":"2026-04-28T13:19:22.290Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-5435","https://security-tracker.debian.org/tracker/CVE-2026-5435"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-5435#Debian:14/glibc","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-5435"}],"summary":"The deprecated functions ns_printrrf, ns_printrr and fp_nquery in the GNU C Library version 2.2 and newer fail to enforce the caller-supplied buffer length, and can result in an out-of-bounds write wh"}