{"action":"Upgrade ruby-json to 2.19.9+dfsg-1 or later.","affected":[{"fixed":"2.19.9+dfsg-1","introduced":"0"}],"component":"ruby-json","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2.19.9+dfsg-1"],"id":"tcs_01M5NSZFZWVVQZSBWMMV4S4PSX","modified_at":"2026-10-26T12:02:58.256919007Z","published_at":"2026-06-30T23:17:28.123Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-54696","https://security-tracker.debian.org/tracker/CVE-2026-54696"],"severity":{"label":"low","score":3.7},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-54696#Debian:14/ruby-json","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-54696"}],"summary":"Ruby JSON is a JSON implementation for Ruby. Versions 2.9.0 through 2.19.8 are vulnerable to heap buffer overflow when the JSON generator is provided with an oversized streamed object. When streaming"}