{"action":"Upgrade ruby-oj to 3.17.3-1 or later.","affected":[{"fixed":"3.17.3-1","introduced":"0"}],"component":"ruby-oj","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.17.3-1"],"id":"tcs_01M5NSZQJAZNGKERK8C3MN9ZD8","modified_at":"2026-10-26T11:47:30.444906067Z","published_at":"2026-07-01T00:16:33.340Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-54900","https://security-tracker.debian.org/tracker/CVE-2026-54900"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-54900#Debian:14/ruby-oj","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-54900"}],"summary":"Oj (Optimized JSON) is a JSON parser and Object marshaller packaged as a Ruby gem. In versions prior to 3.17.2, when in usual mode with create_id enabled, Oj::Parser#parse is vulnerable to heap corrup"}