{"action":"Upgrade thrift to 0.24.0-2 or later.","affected":[{"fixed":"0.24.0-2","introduced":"0"}],"component":"thrift","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.24.0-2"],"id":"tcs_01M5NT12K30CMX8WSSH3B61D0V","modified_at":"2026-10-27T23:00:12.524392297Z","published_at":"2026-07-27T12:16:46.110Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-55971","https://security-tracker.debian.org/tracker/CVE-2026-55971"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-55971#Debian:14/thrift","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-55971"}],"summary":"Heap-based Buffer Overflow vulnerability in Apache Thrift C++ bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue."}