{"action":"Upgrade socat to 1.8.0.3-1+deb13u1 or later.","affected":[{"fixed":"1.8.0.3-1+deb13u1","introduced":"0"}],"component":"socat","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["1.8.0.3-1+deb13u1"],"id":"tcs_01M5NT19TY684D4X8XMMHNJBCR","modified_at":"2026-10-01T03:03:27.070939893Z","published_at":"2026-06-25T17:17:01.967Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-56123","https://security-tracker.debian.org/tracker/CVE-2026-56123"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-56123","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-56123"}],"summary":"socat versions 1.8.0.0 through 1.8.1.1 contain a heap-based buffer overflow vulnerability that allows a malicious SOCKS5 proxy server to overwrite adjacent heap memory by exploiting a sign-extension f"}