{"action":"Upgrade ruby-nokogiri to 1.19.4+dfsg-1 or later.","affected":[{"fixed":"1.19.4+dfsg-1","introduced":"0"}],"component":"ruby-nokogiri","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.19.4+dfsg-1"],"id":"tcs_01M5NT2XFP7GXFF1X7J6Q0YDCC","modified_at":"2026-10-26T11:47:35.897910063Z","published_at":"2026-06-25T15:16:40.493Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-57235","https://security-tracker.debian.org/tracker/CVE-2026-57235"],"severity":{"label":"high","score":8.2},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-57235#Debian:14/ruby-nokogiri","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-57235"}],"summary":"Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, Nokogiri::XML::NodeSet#[] (and its alias #slice) checked the requested index against the node set's"}