{"action":"Upgrade ruby-nokogiri to 1.19.4+dfsg-1 or later.","affected":[{"fixed":"1.19.4+dfsg-1","introduced":"0"}],"component":"ruby-nokogiri","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.19.4+dfsg-1"],"id":"tcs_01M5NT31M60X408K8VTJZJQZ64","modified_at":"2026-10-26T11:47:27.774509535Z","published_at":"2026-06-25T15:16:41.163Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-57436","https://security-tracker.debian.org/tracker/CVE-2026-57436"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-57436#Debian:14/ruby-nokogiri","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-57436"}],"summary":"Nokogiri is an open source XML and HTML library for the Ruby programming language. Prior to 1.19.4, Nokogiri::XML::Document#root= validated only that the new root was a Nokogiri::XML::Node, allowing a"}