{"action":"Upgrade thrift to 0.24.0-2 or later.","affected":[{"fixed":"0.24.0-2","introduced":"0"}],"component":"thrift","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.24.0-2"],"id":"tcs_01M5NT3DZQ6BKPAT3KT63H29WC","modified_at":"2026-10-27T23:00:31.451622242Z","published_at":"2026-07-27T12:16:46.547Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-58023","https://security-tracker.debian.org/tracker/CVE-2026-58023"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-58023#Debian:14/thrift","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-58023"}],"summary":"Out-of-bounds Read vulnerability in Apache Thrift c_glib bindings. This issue affects Apache Thrift: before 0.24.0. Users are recommended to upgrade to version 0.24.0, which fixes the issue."}