{"action":"Upgrade psd-tools to 1.17.4+dfsg.1-1 or later.","affected":[{"fixed":"1.17.4+dfsg.1-1","introduced":"0"}],"component":"psd-tools","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.17.4+dfsg.1-1"],"id":"tcs_01M5NT6RMCHQAYZDN787KMDN9D","modified_at":"2026-09-24T08:47:34.021966209Z","published_at":"2026-09-22T20:17:04.123Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-59991","https://security-tracker.debian.org/tracker/CVE-2026-59991"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-59991#Debian:14/psd-tools","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-59991"}],"summary":"psd-tools is a Python package for working with Adobe Photoshop PSD files. Prior to 1.17.4, PSDImage.composite() and PSDImage.numpy() allocated output buffers from attacker-controlled PSD header geomet"}