{"action":"Upgrade libssh2 to 1.10.0-3+deb12u1 or later.","affected":[{"fixed":"1.10.0-3+deb12u1","introduced":"0"}],"component":"libssh2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["1.10.0-3+deb12u1"],"id":"tcs_01M5NTMWJR7HB7MKPGFG0146AV","modified_at":"2026-10-01T03:03:32.396809303Z","published_at":"2026-07-24T17:17:35.407Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-66034","https://security-tracker.debian.org/tracker/CVE-2026-66034"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-66034","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-66034"}],"summary":"libssh2 through 1.11.1, fixed in commit a13bb6c, contains a missing bounds check vulnerability that allows a malicious SSH server to trigger an arbitrary-length heap out-of-bounds read and a free of a"}