{"action":"Upgrade pgbouncer to 1.25.2-1 or later.","affected":[{"fixed":"1.25.2-1","introduced":"0"}],"component":"pgbouncer","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.25.2-1"],"id":"tcs_01M5NTNHYG9BAGMM4Q606E50R7","modified_at":"2026-10-01T03:03:39.137846965Z","published_at":"2026-05-09T01:16:09.013Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-6665","https://security-tracker.debian.org/tracker/CVE-2026-6665"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-6665#Debian:14/pgbouncer","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-6665"}],"summary":"The SCRAM code in PgBouncer before 1.25.2 did not check the return value of strlcat() correctly when building the contents of the SCRAM client-final-message. A malicious backend that sends a SCRAM ser"}