{"action":"Upgrade node-re2 to 1.26.1+~cs1.7.0-1 or later.","affected":[{"fixed":"1.26.1+~cs1.7.0-1","introduced":"0"}],"component":"node-re2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.26.1+~cs1.7.0-1"],"id":"tcs_01M5NTQ0RHZCQJDMZWNC66G17V","modified_at":"2026-10-24T10:01:16.979733293Z","published_at":"2026-07-30T20:18:15.030Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-67550","https://security-tracker.debian.org/tracker/CVE-2026-67550"],"severity":{"label":"medium","score":5.7},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-67550#Debian:14/node-re2","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-67550"}],"summary":"re2 provides Node.js bindings for Google's RE2 regular expression engine. Prior to 1.25.2, re2 validates lastIndex against the UTF-8 byte length of a subject but uses it as a UTF-16 code-unit offset i"}