{"action":"Upgrade rust-russh to 0.64.1-1 or later.","affected":[{"fixed":"0.64.1-1","introduced":"0"}],"component":"rust-russh","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["0.64.1-1"],"id":"tcs_01M5NV4SRKZ2FK69461NGDJ1EK","modified_at":"2026-10-25T09:47:42.966609330Z","published_at":"2026-08-12T21:17:41.883Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-73430","https://security-tracker.debian.org/tracker/CVE-2026-73430"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-73430","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-73430"}],"summary":"Russh is a Rust SSH client & server library. Prior to 0.62.4, an unauthenticated SSH client can cause a denial of service by sending SSH_MSG_KEX_ECDH_INIT with a 32-byte all-zero Q_C value. Curve25519"}