{"action":"Upgrade ruby-nokogiri to 1.19.3+dfsg-1 or later.","affected":[{"fixed":"1.19.3+dfsg-1","introduced":"0"}],"component":"ruby-nokogiri","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.19.3+dfsg-1"],"id":"tcs_01M5NVN3QVS5RV5P96YXPSYQKG","modified_at":"2026-10-01T03:03:47.264606561Z","published_at":"2026-08-25T16:17:28.603Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-79771","https://security-tracker.debian.org/tracker/CVE-2026-79771"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-79771#Debian:14/ruby-nokogiri","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-79771"}],"summary":"Nokogiri versions before 1.19.3 contain a memory leak in the XSLT Stylesheet transform method when processing Ruby strings containing null bytes. Attackers can exploit this by passing attacker-control"}