{"action":"Upgrade ruby-zip to 3.4.0+dfsg-1 or later.","affected":[{"fixed":"3.4.0+dfsg-1","introduced":"0"}],"component":"ruby-zip","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.4.0+dfsg-1"],"id":"tcs_01M5NVZRMASNXG3XV086X1RH59","modified_at":"2026-09-25T09:00:22.589657786Z","published_at":"2026-09-03T19:17:31.527Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-85396","https://security-tracker.debian.org/tracker/CVE-2026-85396"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-85396#Debian:14/ruby-zip","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-85396"}],"summary":"rubyzip versions before 3.4.0 contain a path traversal vulnerability in Zip::Entry#extract that fails to properly validate extraction paths using prefix comparison without trailing separators. Attacke"}