{"action":"Upgrade zstd-jni-java to 1.5.7-23+ds-1 or later.","affected":[{"fixed":"1.5.7-23+ds-1","introduced":"0"}],"component":"zstd-jni-java","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["1.5.7-23+ds-1"],"id":"tcs_01M5NW4PH2BJTKF9YCC3MRE6M8","modified_at":"2026-10-18T04:00:07.946848544Z","published_at":"2026-09-09T10:22:34.557Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-87795","https://security-tracker.debian.org/tracker/CVE-2026-87795"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-87795#Debian:14/zstd-jni-java","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-87795"}],"summary":"zstd-jni versions before 1.5.7-14 fail to validate offset and length parameters in the ZstdDictCompress constructor, allowing out-of-bounds memory reads. Attackers can supply untrusted offset or lengt"}