{"action":"Upgrade pcre2 to 10.42-1+deb12u1 or later.","affected":[{"fixed":"10.42-1+deb12u1","introduced":"0"}],"component":"pcre2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:12","exploited":false,"fixed_versions":["10.42-1+deb12u1"],"id":"tcs_01M5NW64HFZYFMJ6FP7X4D4EFF","modified_at":"2026-10-01T03:03:43.163804533Z","published_at":"2026-09-11T04:18:03.970Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-89158","https://security-tracker.debian.org/tracker/CVE-2026-89158"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-89158","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-89158"}],"summary":"PCRE2 before 10.48, on 32-bit platforms, has a pcre2_compile_32 integer overflow and resultant out-of-bounds write."}