{"action":"Upgrade pcre2 to 10.48-1 or later.","affected":[{"fixed":"10.48-1","introduced":"0"}],"component":"pcre2","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["10.48-1"],"id":"tcs_01M5NW64S2YTZ5B09F3M0JRBWQ","modified_at":"2026-10-01T03:03:43.163804533Z","published_at":"2026-09-11T04:18:03.970Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-89158","https://security-tracker.debian.org/tracker/CVE-2026-89158"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-89158#Debian:14/pcre2","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-89158"}],"summary":"PCRE2 before 10.48, on 32-bit platforms, has a pcre2_compile_32 integer overflow and resultant out-of-bounds write."}