{"action":"Upgrade freerdp3 to 3.31.0+dfsg-1 or later.","affected":[{"fixed":"3.31.0+dfsg-1","introduced":"0"}],"component":"freerdp3","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["3.31.0+dfsg-1"],"id":"tcs_01M5NWMS4MDNMGNRZDQRWR2NBH","modified_at":"2026-09-25T08:47:22.198729778Z","published_at":"2026-09-15T16:17:46.657Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-91945","https://security-tracker.debian.org/tracker/CVE-2026-91945"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-91945","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-91945"}],"summary":"FreeRDP versions before 3.31.0 contain an out-of-bounds read vulnerability in smartcard response decoders that fail to validate ATR length fields against fixed inline arrays. Authenticated RDP clients"}