{"action":"Upgrade xwayland to 2:24.1.14-1 or later.","affected":[{"fixed":"2:24.1.14-1","introduced":"0"}],"component":"xwayland","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:14","exploited":false,"fixed_versions":["2:24.1.14-1"],"id":"tcs_01M5NWWVV5W10K83V682SCNQHF","modified_at":"2026-10-29T06:00:15.079783295Z","published_at":"2026-10-28T14:17:08.843Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-93517","https://security-tracker.debian.org/tracker/CVE-2026-93517"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-93517#Debian:14/xwayland","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-93517"}],"summary":"A heap buffer overflow in handling GLX RenderLarge request where dataBytes exceeds cmdlen in X.org X server before 21.1.25 and XWayland before 24.1.14 that could be be triggered by an authenticated X"}