{"action":"Upgrade varnish to 7.7.0-3+deb13u2 or later.","affected":[{"fixed":"7.7.0-3+deb13u2","introduced":"0"}],"component":"varnish","cve_ids":[],"ecosystem":"Debian","ecosystem_qualifier":"Debian:13","exploited":false,"fixed_versions":["7.7.0-3+deb13u2"],"id":"tcs_01M5NWYKJPHZT2WW4E6FYF93G5","modified_at":"2026-11-04T16:00:09.439378235Z","published_at":"2026-09-18T21:18:49.297Z","references":["https://osv.dev/vulnerability/DEBIAN-CVE-2026-93894","https://security-tracker.debian.org/tracker/CVE-2026-93894"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"DEBIAN-CVE-2026-93894#Debian:13/varnish","url":"https://osv.dev/vulnerability/DEBIAN-CVE-2026-93894"}],"summary":"In Vinyl Cache before 9.0,2, workspace buffer overflow vulnerability was found in the .upper() and .lower() string type methods of VCL. This can be used as a remote denial of service (DoS) vector to m"}