{"action":"Upgrade ruby to 3.4.12-r0 or later.","affected":[{"fixed":"3.4.12-r0","introduced":"0"}],"component":"ruby","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.24","exploited":false,"fixed_versions":["3.4.12-r0"],"id":"tcs_01M5XGAD1ZG30TABRHB1KA6KTZ","modified_at":"2026-10-27T12:30:03.218658685Z","published_at":"2026-09-24T00:17:22.060Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-89078","https://security.alpinelinux.org/vuln/CVE-2026-89078"],"severity":{"label":"critical","score":9.9},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-89078","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-89078"}],"summary":"GitLab has remediated an issue in GitLab CE/EE affecting all versions from 19.2 before 19.2.7, 19.3 before 19.3.3, and 19.4 before 19.4.1 that under certain conditions could have allowed an authentica"}