{"action":"Upgrade caddy to 2.11.2-r0 or later.","affected":[{"fixed":"2.11.2-r0","introduced":"2.7.5"}],"component":"caddy","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["2.11.2-r0"],"id":"tcs_01M6G9HVMK3NGA7JPK736ERTBS","modified_at":"2026-11-03T06:30:16.832311756Z","published_at":"2026-03-07T17:15:52.733Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2026-30852","https://security.alpinelinux.org/vuln/CVE-2026-30852"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2026-30852","url":"https://osv.dev/vulnerability/ALPINE-CVE-2026-30852"}],"summary":"Caddy is an extensible server platform that uses TLS by default. From version 2.7.5 to before version 2.11.2, the vars_regexp matcher in vars.go:337 double-expands user-controlled input through the Ca"}