{"action":"Upgrade ruby2.2 to 2.2.8-r0 or later.","affected":[{"fixed":"2.2.8-r0","introduced":"0"}],"component":"ruby2.2","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.5","exploited":false,"fixed_versions":["2.2.8-r0"],"id":"tcs_01M6GA2FDGX667PG85DPSW4EJ6","modified_at":"2026-11-03T06:30:24.432558748Z","published_at":"2017-09-19T17:29:00.263Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-10784","https://security.alpinelinux.org/vuln/CVE-2017-10784"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-10784#Alpine:v3.5/ruby2.2","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-10784"}],"summary":"The Basic authentication code in WEBrick library in Ruby before 2.2.8, 2.3.x before 2.3.5, and 2.4.x through 2.4.1 allows remote attackers to inject terminal emulator escape sequences into its log and"}