{"action":"Upgrade xorg-server to 1.19.5-r0 or later.","affected":[{"fixed":"1.19.5-r0","introduced":"0"}],"component":"xorg-server","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.16","exploited":false,"fixed_versions":["1.19.5-r0"],"id":"tcs_01M6GA9MA5GGNE88Y8F42RNX02","modified_at":"2026-11-03T06:30:26.624264266Z","published_at":"2018-01-24T15:29:00.620Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-12182","https://security.alpinelinux.org/vuln/CVE-2017-12182"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-12182#Alpine:v3.16/xorg-server","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-12182"}],"summary":"xorg-x11-server before 1.19.5 was missing length validation in XFree86 DRI extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code."}