{"action":"Upgrade xorg-server to 1.19.5-r0 or later.","affected":[{"fixed":"1.19.5-r0","introduced":"0"}],"component":"xorg-server","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.15","exploited":false,"fixed_versions":["1.19.5-r0"],"id":"tcs_01M6GAMJKZKHVJAZ9AVQB0EWVM","modified_at":"2026-11-03T06:30:32.223992935Z","published_at":"2018-01-24T15:29:00.840Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-12185","https://security.alpinelinux.org/vuln/CVE-2017-12185"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-12185#Alpine:v3.15/xorg-server","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-12185"}],"summary":"xorg-x11-server before 1.19.5 was missing length validation in MIT-SCREEN-SAVER extension allowing malicious X client to cause X server to crash or possibly execute arbitrary code."}