{"action":"Upgrade libzip to 1.2.0-r2 or later.","affected":[{"fixed":"1.2.0-r2","introduced":"0"}],"component":"libzip","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.6","exploited":false,"fixed_versions":["1.2.0-r2"],"id":"tcs_01M6GAN49P20HXEJWRYJZFQW10","modified_at":"2026-11-03T06:30:32.458766952Z","published_at":"2017-09-01T17:29:00.260Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-14107","https://security.alpinelinux.org/vuln/CVE-2017-14107"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-14107#Alpine:v3.6/libzip","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-14107"}],"summary":"The _zip_read_eocd64 function in zip_open.c in libzip before 1.3.0 mishandles EOCD records, which allows remote attackers to cause a denial of service (memory allocation failure in _zip_cdir_grow in z"}