{"action":"Upgrade libsoup to 2.58.2-r0 or later.","affected":[{"fixed":"2.58.2-r0","introduced":"0"}],"component":"libsoup","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.13","exploited":false,"fixed_versions":["2.58.2-r0"],"id":"tcs_01M6GAQCE1R95YRH51BV423WNA","modified_at":"2026-11-03T06:30:33.643839028Z","published_at":"2018-04-24T19:29:02.783Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-2885","https://security.alpinelinux.org/vuln/CVE-2017-2885"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-2885#Alpine:v3.13/libsoup","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-2885"}],"summary":"An exploitable stack based buffer overflow vulnerability exists in the GNOME libsoup 2.58. A specially crafted HTTP request can cause a stack overflow resulting in remote code execution. An attacker c"}