{"action":"Upgrade gtk-vnc to 0.7.0-r0 or later.","affected":[{"fixed":"0.7.0-r0","introduced":"0"}],"component":"gtk-vnc","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.12","exploited":false,"fixed_versions":["0.7.0-r0"],"id":"tcs_01M6GAWB9TDEM7ZRVDFP156TE9","modified_at":"2026-11-03T06:30:34.923937697Z","published_at":"2017-02-28T18:59:00.407Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-5884","https://security.alpinelinux.org/vuln/CVE-2017-5884"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-5884#Alpine:v3.12/gtk-vnc","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-5884"}],"summary":"gtk-vnc before 0.7.0 does not properly check boundaries of subrectangle-containing tiles, which allows remote servers to execute arbitrary code via the src x, y coordinates in a crafted (1) rre, (2) h"}