{"action":"Upgrade gtk-vnc to 0.7.0-r0 or later.","affected":[{"fixed":"0.7.0-r0","introduced":"0"}],"component":"gtk-vnc","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.16","exploited":false,"fixed_versions":["0.7.0-r0"],"id":"tcs_01M6GBXDGW4RYBA4PZF8CF4WJZ","modified_at":"2026-11-03T06:30:48.445513779Z","published_at":"2017-02-28T18:59:00.453Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2017-5885","https://security.alpinelinux.org/vuln/CVE-2017-5885"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2017-5885#Alpine:v3.16/gtk-vnc","url":"https://osv.dev/vulnerability/ALPINE-CVE-2017-5885"}],"summary":"Multiple integer overflows in the (1) vnc_connection_server_message and (2) vnc_color_map_set functions in gtk-vnc before 0.7.0 allow remote servers to cause a denial of service (crash) or possibly ex"}