{"action":"Upgrade redis to 5.0.4-r0 or later.","affected":[{"fixed":"5.0.4-r0","introduced":"3.0.0"}],"component":"redis","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.23","exploited":false,"fixed_versions":["5.0.4-r0"],"id":"tcs_01M6GC128MZCP2ZDDS09GKTEVN","modified_at":"2026-11-03T06:30:51.600595961Z","published_at":"2019-07-11T19:15:12.627Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-10192","https://security.alpinelinux.org/vuln/CVE-2019-10192"],"severity":{"label":"high","score":7.2},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-10192#Alpine:v3.23/redis","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-10192"}],"summary":"A heap-buffer overflow vulnerability was found in the Redis hyperloglog data structure versions 3.x before 3.2.13, 4.x before 4.0.14 and 5.x before 5.0.4. By carefully corrupting a hyperloglog using t"}