{"action":"Upgrade opensc to 0.19.0-r0 or later.","affected":[{"fixed":"0.19.0-r0","introduced":"0"}],"component":"opensc","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.11","exploited":false,"fixed_versions":["0.19.0-r0"],"id":"tcs_01M6GDS6K69MXYTCD5DS398P9J","modified_at":"2026-11-03T06:31:16.902323192Z","published_at":"2018-09-03T14:29:00.513Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2018-16393","https://security.alpinelinux.org/vuln/CVE-2018-16393"],"severity":{"label":"medium","score":6.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2018-16393#Alpine:v3.11/opensc","url":"https://osv.dev/vulnerability/ALPINE-CVE-2018-16393"}],"summary":"Several buffer overflows when handling responses from a Gemsafe V1 Smartcard in gemsafe_get_cert_len in libopensc/pkcs15-gemsafeV1.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supp"}