{"action":"Upgrade opensc to 0.19.0-r0 or later.","affected":[{"fixed":"0.19.0-r0","introduced":"0"}],"component":"opensc","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["0.19.0-r0"],"id":"tcs_01M6GDSAAGPHMV4X2K34XDBHP5","modified_at":"2026-11-03T06:31:16.904921166Z","published_at":"2018-09-04T00:29:00.230Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2018-16418","https://security.alpinelinux.org/vuln/CVE-2018-16418"],"severity":{"label":"medium","score":6.6},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2018-16418#Alpine:v3.19/opensc","url":"https://osv.dev/vulnerability/ALPINE-CVE-2018-16418"}],"summary":"A buffer overflow when handling string concatenation in util_acl_to_str in tools/util.c in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to cause a denial of se"}