{"action":"Upgrade opensc to 0.19.0-r0 or later.","affected":[{"fixed":"0.19.0-r0","introduced":"0"}],"component":"opensc","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.12","exploited":false,"fixed_versions":["0.19.0-r0"],"id":"tcs_01M6GDVC6XEVKVQT59EB923Z47","modified_at":"2026-11-03T06:31:19.848400987Z","published_at":"2018-09-04T00:29:01.417Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2018-16427","https://security.alpinelinux.org/vuln/CVE-2018-16427"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2018-16427#Alpine:v3.12/opensc","url":"https://osv.dev/vulnerability/ALPINE-CVE-2018-16427"}],"summary":"Various out of bounds reads when handling responses in OpenSC before 0.19.0-rc1 could be used by attackers able to supply crafted smartcards to potentially crash the opensc library using programs."}