{"action":"Upgrade ruby-nokogiri to 1.10.4-r0 or later.","affected":[{"fixed":"1.10.4-r0","introduced":"0"}],"component":"ruby-nokogiri","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.22","exploited":false,"fixed_versions":["1.10.4-r0"],"id":"tcs_01M6GHDBNMCVGS7JDRHCZQSQYA","modified_at":"2026-11-03T06:31:58.389370386Z","published_at":"2019-08-16T16:15:10.637Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-5477","https://security.alpinelinux.org/vuln/CVE-2019-5477"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-5477#Alpine:v3.22/ruby-nokogiri","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-5477"}],"summary":"A command injection vulnerability in Nokogiri v1.10.3 and earlier allows commands to be executed in a subprocess via Ruby's `Kernel.open` method. Processes are vulnerable only if the undocumented meth"}