{"action":"Upgrade assimp to 5.4.3-r0 or later.","affected":[{"fixed":"5.4.3-r0","introduced":"0"}],"component":"assimp","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.22","exploited":false,"fixed_versions":["5.4.3-r0"],"id":"tcs_01M6GHXMJ57F75E7XDCV09YN5G","modified_at":"2026-11-03T06:32:08.614704734Z","published_at":"2024-07-19T08:15:02.070Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2024-40724","https://security.alpinelinux.org/vuln/CVE-2024-40724"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2024-40724#Alpine:v3.22/assimp","url":"https://osv.dev/vulnerability/ALPINE-CVE-2024-40724"}],"summary":"Heap-based buffer overflow vulnerability in Assimp versions prior to 5.4.2 allows a local attacker to execute arbitrary code by inputting a specially crafted file into the product."}