{"action":"Upgrade php81 to 8.1.29-r0 or later.","affected":[{"fixed":"8.1.29-r0","introduced":"0"}],"component":"php81","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.19","exploited":false,"fixed_versions":["8.1.29-r0"],"id":"tcs_01M6GHY0TQ2HRRMFFXZR7G8DYW","modified_at":"2026-11-03T06:32:09.111449541Z","published_at":"2024-06-09T20:15:09.550Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2024-4577","https://security.alpinelinux.org/vuln/CVE-2024-4577"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2024-4577","url":"https://osv.dev/vulnerability/ALPINE-CVE-2024-4577"}],"summary":"In PHP versions 8.1.* before 8.1.29, 8.2.* before 8.2.20, 8.3.* before 8.3.8, when using Apache and PHP-CGI on Windows, if the system is set up to use certain code pages, Windows may use \"Best-Fit\" be"}