{"action":"Upgrade pdns to 4.1.7-r0 or later.","affected":[{"fixed":"4.1.7-r0","introduced":"0"}],"component":"pdns","cve_ids":[],"ecosystem":"Alpine","ecosystem_qualifier":"Alpine:v3.22","exploited":false,"fixed_versions":["4.1.7-r0"],"id":"tcs_01M6GJVT9JF0RNPV6TW33D0V2C","modified_at":"2026-11-03T06:32:18.210802156Z","published_at":"2019-03-21T21:29:00.700Z","references":["https://osv.dev/vulnerability/ALPINE-CVE-2019-3871","https://security.alpinelinux.org/vuln/CVE-2019-3871"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"ALPINE-CVE-2019-3871#Alpine:v3.22/pdns","url":"https://osv.dev/vulnerability/ALPINE-CVE-2019-3871"}],"summary":"A vulnerability was found in PowerDNS Authoritative Server before 4.0.7 and before 4.1.7. An insufficient validation of data coming from the user when building a HTTP request from a DNS query in the H"}